1. Home
  2. Troubleshooting
  3. Troubleshooting VisualSP On-Premises
  4. “The web.config is missing from this IIS Web Site” Error Message When Upgrading or Installing VisualSP On-Prem

“The web.config is missing from this IIS Web Site” Error Message When Upgrading or Installing VisualSP On-Prem

Applies to: VisualSP On-Premises
Print Friendly, PDF & Email

Problem

When installing or upgrading VisualSP On-Premises, you may encounter an error message stating, “The web.config is missing from this IIS Web Site”.

Cause

This error indicates there is something going on with your environment and the SharePoint solution deployment process. The actual solution deployment and retraction is handled by SharePoint and is completely out of our control.

Troubleshooting Steps

Our recommendations:

  1. Use central admin to manually retract the solution.
  2. You may also need to stop and restart the web application service on the server where it’s failing so that it will recreate the IIS sites (note that if you do this then you’ll have to redo any manual configuration settings for each web application (SSL, IPs, web.config changes, etc.)). We suggest you backup the virtual directories of the existing sites before you attempt this. It may be necessary to redeploy solutions but you shouldn’t have to do that as SharePoint should detect that the solution is needed on the web application.
  3. Open a ticket with Microsoft to debug the solution deployment process in your environment.
Updated on November 12, 2018

Related Articles